*
*
Home
Help
Login
Register
Welcome, Guest. Please login or register.
May 23, 2022, 03:03:40 PM

Login with username, password and session length
Forum changes: Editing of posts has been turned off until further notice.
Search:     Advanced search
275647 Posts in 27717 Topics by 4285 Members Latest Member: - Jason DAngelo Most online today: 89 - most online ever: 565 (October 17, 2020, 02:08:06 PM)
Pages: [1]
Print
Author Topic: Problem reading the forums.  (Read 6732 times)
Federico Figueredo
Member

Posts: 6


« on: May 24, 2007, 05:25:33 AM »

Good day to you all. I'm a complete newcomer to the forums and since this *is* my first post I thought some greetings wouldn't be that bad. But to stay within my topic, I was wondering about a little problem I have with the forums. The thing is, 90% of the text is italized. This, which I consider is great for text, is actually hampering my reading a bit (I don't know why, but it does -weird-) and I was wondering if you were using it on purpose (like on a forum theme -haven't used this kind of forums myself, so I'm just fishing here-) and if so if there was some way to disable it on my PC.

Now, I have tried setting personal preferences in my browser, but believe it or not I can't get the bloody thing to work. I know it shouldn't be such a big deal, but if someone has an idea I would be more than happy to go with it.

Last but not least, I hope I posted in the right place, it did seem like the most apropiate forum and after a simple search I couldn't find any other message with the same problem.

So thanks in advance, and see you around.

Federico Figueredo from Argentina.
Logged

Federico Figueredo
lumpley
Administrator
Member
*
Posts: 3453


WWW
« Reply #1 on: May 24, 2007, 06:24:45 AM »

Hi Frederico, welcome. I'm Vincent, I'm an administrator here.

Well, in your post here most of it's italicized because you didn't close your <em> tag.

Could you point me to a post that's showing up mostly italicized to you out in the forums at large? I glanced over them and everything looks fine on my computer, but I might have missed something.

Thanks!

-Vincent
Logged
Federico Figueredo
Member

Posts: 6


« Reply #2 on: May 24, 2007, 08:05:50 AM »

First of all, hi Vicent, pleased to meet you. Second, sorry about the *em* tag, I didn't think HTML would work on the post. Third, actually I see everythihng inside a post as being italized on all posts. For example, the post name might be in normal text, as the forum names, but any further description plus the content of the posts themselves is italized.

So it is quite of a bothersome thingie for me. Any ideas? (I checked with two browsers and I'm getting the same rendering of the website so ...)

Thanks again.

Federico Figueredo.
Logged

Federico Figueredo
lumpley
Administrator
Member
*
Posts: 3453


WWW
« Reply #3 on: May 24, 2007, 08:21:17 AM »

Strange!

Hey, anybody who reads this, could I get a good handful of you to tell me whether you see what Federico sees? Has this been going on for a while and he's the first to mention it?

(Sorry about misspelling your name the first time.)

-Vincent
Logged
Moreno R.
Member

Posts: 389


« Reply #4 on: May 24, 2007, 08:38:36 AM »

I see everything fine (I am using IE 6.0).
Logged

Ciao,
Moreno.

(Excuse my errors, English is not my native language. I'm Italian.)
Federico Figueredo
Member

Posts: 6


« Reply #5 on: May 24, 2007, 08:54:31 AM »

Thanks again for your swift replies in this matter. Tell you what, I need to leave now to go to the doctor, and I'll be back later today. I'll leave you screenshots of the situation in different browsers and try the ones you're telling me.

Have a nice day. By the way, I'm at GMT -3 how about you all?

Federico Figueredo.
Logged

Federico Figueredo
Christoph Boeckle
Member

Posts: 455

Geneva, Switzerland


WWW
« Reply #6 on: May 24, 2007, 10:50:44 AM »

Everything here is fine in Mozilla Firefox 2.0.0.3, running on Ubuntu 7.04.
Logged

Regards,
Christoph
Federico Figueredo
Member

Posts: 6


« Reply #7 on: May 24, 2007, 02:30:35 PM »

Hey guys, I collected for you all a set of screenies in 4 different browsers showing my particula predicament. The testers are Opera (latest version), Internet Explorer 7, Seamonkey and dear old Firefox. The results are below, in small captions (hopefully) to help load times. As you'll see the text has been italized (thank god it's not oblique, they I would surely die trying to read it). The only one that comes out on top of the pack is IE7 ... and it does because it just renders the text in that funky all way that IE usually does.

  • Opera


  • Internet Explorer 7


  • Seamonkey


  • Firefox

[/list]

Any ideas?
Logged

Federico Figueredo
Paul Czege
Acts of Evil Playtesters
Member

Posts: 2341


WWW
« Reply #8 on: May 24, 2007, 06:19:59 PM »

Across multiple browsers? My guess would be a font substitution problem. The Forge CSS specifies a list of fonts for the browser to attempt, and your system lacks anything close, and so it complies as best it can with an italic font. I'm no CSS expert by any stretch of the imagination, but a quick look suggests that you might try installing Tahoma.

Paul
Logged

My Life with Master knows codependence.
And if you're doing anything with your Acts of Evil ashcan license, of course I'm curious and would love to hear about your plans
Federico Figueredo
Member

Posts: 6


« Reply #9 on: May 25, 2007, 12:26:59 AM »

That is what I thought about in the first place as well, however when the font-family property is set on CSS usually the statement is a list of possible fonts (from the most preffered, going down to second and third choices) ended with a "serif" or "sans-serif" (I aplogise if I'm forgetting the spelling, it's 5am in the morning and quite frankly my mental engine is running on fumes) to avoid that kind of problem (i.e. the viewer not having the font and messy things happening).

Of course, I have no idea of what your CSS looks like, so really I'm just guessing. I will install Tahoma though, it's odd but I thought I had it in the system. Now that I'm looking at it, it's rather odd but I don't think that is the problem.

Which leads me to ...

Update!!

I've noticed that although in other pages the text doesn't render in italics, the imput fields (mostly text such as this one) are being italized, something that (if I recall correctly doesn't usually happen). It's an oddity alright, but I'm stuck with the problem. Any insights?

Thanks again for your time and help.
Logged

Federico Figueredo
Eero Tuovinen
Acts of Evil Playtesters
Member

Posts: 2591


WWW
« Reply #10 on: May 25, 2007, 01:03:10 AM »

What a weird problem. Common sense would suggest that it's a problem with the individual computer set-up, though, as others are not suffering from it.

You have probably tried surfing around, and other sites are not suffering from this, right? How about, have you checked any cache sites for mirrored Forge pages? Might provide something useful to check if a Google cache or similar has the same problem, especially if you compared pages from before and after the latest upgrades here.

Vincent: is there any fancy content-negotiation going on in the headers of the site? Federico's browser might be sending some strange preferences, which are then used to send something strange back. Although as far as I know the only way to get that kind of clean cursive all over the place would be to set it as a CSS property for the paragraph style.
Logged

Blogging at Game Design is about Structure.
Publishing Zombie Cinema and Solar System at Arkenstone Publishing.
Federico Figueredo
Member

Posts: 6


« Reply #11 on: May 25, 2007, 10:30:34 AM »

Ok, I was going to address a couple things directly (like the suggestion of getting the Tahoma font, which I actually have), but I think I'll cut straight to the proverbial chase.

I think I found the problem here.

I took a glimpse of your CSS and did some replacing of my own (pretty much, used my own style sheet on your site using the User mode in the browser), and found out two things. First of all (and this might be due to the nature of PHP, I have no idea of how it works yet), you must be using more than one CSS sheet or you must be working some other kind of funky magic, simply because replacing your style sheet for an identical one in my computer, gets rid of all the borders and the logo and stuff like that. Again, that is just probably PHP.

But the second one is where I think the answer is. Your fonts are defined in both the body element, and the tabular data element (body and td), and plus some other places (I had to do some replacing and I found font settings in about 4 or 5 different places) as:

Code:
font-family: serif, sans-serif

This is what I think is causing the problem. Simply replacing said code with:

Code:
font-family: Verdana, Arial, sans-serif, serif;

did the trick for me. I could see everything non italized. Most likely due to the fonts in my PC the browsers are picking (god knows why) some set of sans-serif that *looks* italized in your default small font size. From the look of the style sheet I also see that most likely someone made the style for you or this is a standard style made available for downloads (just guessing from the comments). While it is odd that no one has had the same problem, you can bet that a lot of people will have different renderings. And this is not bad per se (I mean, sure enough, everyone will get a sans-serif font and if they don't have any ... which won't really happen ... they'll get a serif font), but it would be nice if you could set it up to something before (obviously I'd love that since it would solve my problem, but hey, the site *would* be more consistently rendered so ...).

Just in case, I will look into user overriding methods so ... why don't you tell me what do you think. If someone thinks it's something else please do tell, I'm all ears.
Logged

Federico Figueredo
Pages: [1]
Print
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC
Oxygen design by Bloc
Valid XHTML 1.0! Valid CSS!